From Documentation
Revision as of 23:18, 3 April 2012 by Isaac (Talk | contribs) (Created page with "{{Software |package_name=LUMERICAL |package_description=Providing photonic and optoelectronic TCAD device simulation and photonic integrated circuit design products |package_idnu...")

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search
LUMERICAL
Description: Providing photonic and optoelectronic TCAD device simulation and photonic integrated circuit design products
SHARCNET Package information: see LUMERICAL software page in web portal
Full list of SHARCNET supported software


ACCOUNT PREPARATION (version 6 only)

Before running lumerical on requin or rainbow verify that the following "ini" file exists and contains the server and type line as shown. If it doesnt exist created it. Note that if you have been running version 7 jobs the "ini" file might be corrupted and need to be re-created:

1) First create the directory using the following command:

mkdir -p ~/.config/Lumerical 

2) Using an editor (such as vi) open the "ini" file:


vi .config/Lumerical/"FDTD Solutions.ini"


3) Paste in the following 3 lines and save the file:

[license]
server\host=db.uwo.sharcnet
type=floating


LOADING LUMERICAL MODULE

Before you can run Lumerical version 7.5.2 or newer, you must load the Lumerical module:

module load lumerical

THE FDTD GUI - INTERACTIVE USAGE EXAMPLE

The graphical interface on SHARCNET's system is named CAD. To run CAD remotely on the login nodes (or tope) from a windows desktop, one needs an X server running on the local desktop. We recommend using Xming + Putty [1] or Cygwin/X[2]. They are all free. Or if your connecting from a linux desktop then run the "ssh -X clustername" command for instance:

ssh -X tope.sharcnet.ca
module load lumerical
cd /scratch/$USER
cp /opt/sharcnet/lumerical/7.5.2/examples/paralleltest.fsp .
CAD paralleltest.fsp


SUBMITTING A PARALLEL JOB - VERSION 6

Due to system level incompatibilities on requin and rainbow the latest version of lumerical cannot be installed. Therefore the previous non-modularized version 6 remains on these systems. Since as before the binaries are found by default in your path to run a job simply requires doing:

sqsub -test -q mpi -r 59m -n 16 -o ofile.%J FDTD-par-hpmpi-lcl paralleltest.fsp

SUBMITTING A PARALLEL JOB - VERSION 7

Starting with version 7 the lumerical module must be loaded first before submitting a job or running the CAD command for instance as follows:

module load lumerical/7.5.2
sqsub -q mpi -r 1.5h -n 16 -o ofile%J fdtd-engine-ompi-lcl paralleltest.fsp


For further details about Distributed simulation testing please refer to the documentation on Lumerical's web site which can be found here[3].