Contact Tool

The Contact Tool allows you to examine contact conditions on an assembly both before loading, and as part of the final solution to verify the transfer of loads (forces and moments) across the various contact regions. The Contact Tool is an object you can insert under a Connections branch object for examining initial contact conditions, or under a Solution or Solution Combination branch object for examining the effects of contact as part of the solution. The Contact Tool allows you to conveniently scope contact results to a common selection of geometry or contact regions. In this way, all applicable contact results can be investigated at once for a given scoping.

A Contact Tool is scoped to a given topology, and there exist two methods for achieving this: the Worksheet method and the Geometry Selection method. Under the Worksheet method, the Contact Tool is scoped to one or more contact regions. Under the Geometry Selection method, the Contact Tool can be scoped to any geometry on the model. Regardless of the method, the scoping on the tool is applied to all results grouped under it.

To use a Contact Tool, prepare a structural analysis for an assembly with contacts. You then use either the Geometry Selection or Worksheet scoping method for results.

Evaluating Initial Contact Conditions


Note:  To calculate initial contact results, the Contact Tool assumes small deflection. This assumption impacts the resulting pinball radius of the scoped contacts if their Pinball Region property is set to Program Controlled.


To evaluate initial contact conditions using the Worksheet method:

  1. Insert a Contact Tool in the Connections folder (Contact Tool from the Connections context toolbar, or right mouse button click on Connections, then Insert> Contact Tool). You will see a Contact Tool inserted that includes a default Initial Information object.

  2. In the Details view of the Contact Tool, ensure that Worksheet (the default) is selected in the Scoping Method field. The Worksheet appears. Scoped contact regions are those that are checked in the table.

  3. You can modify your selection of contact regions in the Worksheet using the following procedures:

    • To add or remove pre-selected groups of contact regions (All Contacts, Nonlinear Contacts, or Linear Contacts), use the drop-down menu and the corresponding buttons.

    • To add any number of contact regions, you can also drag-drop or copy-paste any number of contact regions from the Connections folder into the Contact Tool in the Tree View. Also, one or more contact regions can be deleted from the Contact Tool worksheet by selecting them in the table and pressing the Delete key.

    • To change the Contact Side of all contact regions, choose the option in the drop-down menu (Both, Contact, or Target from the drop-down menu and click the Apply button).

    • To change an individual Contact Side, click in the particular cell and choose Both, Contact, or Target from the drop-down menu.

  4. Add contact result objects of interest under the Contact Tool folder (Contact> Penetration or Gap or Status from the Contact Tool context toolbar, or right mouse button click on Contact Tool, then Insert> Penetration or Gap or Status). The specific contact result objects are inserted.

  5. Obtain the initial contact results using a right mouse button click on the Contact object, or Contact Tool object, or any object under the Contact Tool object, then choosing Generate Initial Contact Results from the context menu. Results are displayed as follows:

    • When you highlight the Initial Information object, a table appears in the Worksheet that includes initial contact information for the contact regions that you specified in step 2 above. You can display or hide the various columns in the table. The table rows display in various colors that indicate the detected contact conditions. A brief explanation of each color is provided in the legend that is displayed beneath the table. Copies of the legend explanations are presented below in quotes, followed by more detailed explanations.

      • Red: "The contact status is open but the type of contact is meant to be closed. This applies to bonded and no separation contact types."

        Workbench has detected an open contact Status condition, which is invalid based on the definitions of Bonded and No Separation contact types. It is very likely that the model will not be held together as expected. The geometry of the contact may be too far apart for the closed condition to be satisfied. Review of the Contact Region definition is strongly recommended.

      • Yellow: "The contact status is open. This may be acceptable."

        Workbench has detected an open contact Status condition on a nonlinear contact type, Frictionless, Rough, or Frictional, which is probably acceptable under certain conditions as stated in their descriptions.

        If the Status is Far Open, the Penetration and the Gap will be set to zero even though the Resulting Pinball is non-zero.


        Note:  Currently, contact results are not saved to results (.rst) file for all contact elements that are outside the pinball region to optimize the file size. Results for far field contact elements were reported as zero in prior releases.


      • Orange: "The contact status is closed but has a large amount of gap or penetration. Check penetration and gap compared to pinball and depth.”

        Workbench has detected that any of the following contact results are greater than 1/2 of the Resulting Pinball, or greater than 1/2 of the Contact Depth: Gap, Penetration, maximum closed Gap, maximum closed Penetration. This could lead to poor results in terms of stiffness of the contacting interface. It is recommended that you alter the geometry to reduce the gap or penetration.

      • Gray: "Contact is inactive. This can occur for MPC and Normal Lagrange formulations. It can also occur for auto asymmetric behavior."

        Refer to the individual descriptions for the MPC and Normal Lagrange formulations, and the description for Auto Asymmetric behavior.


    Note:  The “not applicable” designation, N/A appears in the following locations and situations:


    • When you highlight any of the contact result objects, the Geometry tab appears and displays the graphical result for the contact regions that you specified in step 2 above.

To evaluate initial contact conditions using the Geometry Selection method:

  1. Select one or more bodies that are in contact.

  2. Insert a Contact Tool in the Connections folder (Contact Tool from the Connections context toolbar, or right mouse button click on Connections, then Insert> Contact Tool). You will see a Contact Tool inserted that includes a default Initial Information object.


    Note:  The scoping of the Initial Information object is only available using the Worksheet method. Selecting bodies as in step 1 above has no effect on Initial Information results.


  3. In the Details view of the Contact Tool, select Geometry Selection in the Scoping Method field. The bodies that you selected in step 1 are highlighted in the Geometry tab.

  4. Add contact result objects of interest under the Contact Tool folder (Contact> Penetration or Gap or Status from the Contact Tool context toolbar, or right mouse button click on Contact Tool, then Insert> Penetration or Gap or Status). The specific contact result objects are inserted.

  5. Obtain the initial contact results using a right mouse button click on the Contact object, or Contact Tool object, or any object under the Contact Tool object, then choosing Generate Initial Contact Results from the context menu. When you highlight any of the contact result objects, the Geometry tab appears and displays the graphical result for the bodies that you selected in step 1.

Evaluating Contact Conditions After Solution


Note:  The default method will be the last one that you manually chose in the Scoping Method drop down menu. If you have already selected geometry, the Scoping Method field automatically changes to Geometry Selection. The default however will not change until you manually change the Scoping Method entry.


To evaluate contact conditions after solution using the Worksheet method:

  1. Insert a Contact Tool in the Solution folder (Tools> Contact Tool from the Solution context toolbar, or right mouse button click on Solution, then Insert> Contact Tool> Contact Tool). You will see a Contact Tool inserted with a default contact result.

  2. In the Details view, select Worksheet in the Scoping Method field. The Worksheet appears. Scoped contact regions are those that are checked in the table.

  3. You can modify your selection of contact regions in the Worksheet using the following procedures:

    • To add or remove pre-selected groups of contact regions (All Contacts, Nonlinear Contacts, or Linear Contacts), use the drop-down menu and the corresponding buttons.

    • To add any number of contact regions, you can also drag-drop or copy-paste any number of contact regions from the Contact folder into the Contact Tool in the Tree View. Also, one or more contact regions can be deleted from the Contact Tool worksheet by selecting them in the table and pressing the Delete key.

    • To change the Contact Side of all contact regions, choose the option in the drop-down menu (Both, Contact, or Target from the drop-down menu and click the Apply button).

    • To change an individual Contact Side, click in the particular cell and choose Both, Contact, or Target from the drop-down menu.

  4. Add more contact results as needed in the Contact Tool folder (Contact> [Contact Result, for example, Pressure] from the Contact Tool context toolbar, or right mouse button click on Contact Tool, then Insert> [Contact Result, for example, Pressure]).

  5. Solve database. Upon completion, you will see contact results with the common scoping of the Contact Tool.

To evaluate contact conditions after solution using the Geometry Selection method:

  1. Select one or more bodies that are in contact.

  2. Insert a Contact Tool in the Solution folder (Tools> Contact Tool from the Solution context toolbar, or right mouse button click on Solution, then Insert> Contact Tool> Contact Tool). You will see a Contact Tool inserted with a default contact result. Because you have already selected one or more bodies, Geometry Selection is automatically set in the Scoping Method field within the Details view.

  3. Add more contact results as needed in the Contact Tool folder (Contact> [Contact Result, for example, Pressure] from the Contact Tool context toolbar, or right mouse button click on Contact Tool, then Insert> [Contact Result, for example, Pressure]).

  4. Solve database. Upon completion, you will see contact results with the common scoping of the Contact Tool.

The configuration of the Contact Tool, in particular the location (Solution vs Solution Combination) and the scoping method, affects the availability of results. A Contact Tool in the Solution Combination folder has the limitation that it supports only pressure, frictional stress, penetration and distance.


Release 17.0 - © SAS IP, Inc. All rights reserved.